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Intermediate Microsoft Excel 
Part 2: List and Data Management  

 
Introduction: 
 
 Most organizations maintain data in the form of lists. Companies have lists of their employees. 
Magazines and newspapers keep lists of their subscribers. This section presents the fundamentals of list 
management as it is implemented in Excel. We begin with the definition of basic terms, such as field and 
record, then cover the commands to create a list, to add a new record, or to modify or delete an 
existing record. 
 
 Through the Hands-on Exercises, we will introduce the AutoFilter and Advanced Filter commands 
that display selected records in a list. We use the Sort command to rearrange the list. We also discuss 
database functions and the associated criteria range. This set of exercises will end with an application of 
the subtotals command and generation of a pivot table. 
 
 
Learning Objectives: 
 
When you have finished the second part of this course you will be able to: 
 
1. Create a list within Excel; explain the importance of proper planning and design prior to creating 

the list; 
2. Add, edit, and delete records in an existing list; explain the significance of data validation; 
3. Describe the TODAY and NOW functions and explain the use of date arithmetic; 
4. Use the SORT command; distinguish between an ascending and a descending sort, and among 

primary, secondary, and tertiary keys; 
5. Use the DSUM, DAVERAGE, DMAX, DMIN, and DCOUNT functions; 
6. Use the AutoFilter and Advanced Filter commands to display a subset of a list; 
7. Create Subtotals in a list; and  
8. Generate a pivot table and explain how it provides flexibility in data analysis. 
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Hands-on Exercise 1 
Creating and Maintaining a List 
 
Objectives: To add, edit, and delete records in an employee list; to introduce the Data Form and 

Data Sort commands, to use spell check to validate data.  
 
Step 1: Open the Employee Workbook 

Ø Start Excel. Open the Employees.xls workbook … 

Ø Save the workbook to a floppy disk or Datastore01\home if you want to keep a record of your 
changes. 

 
Step 2: Add a Record Using Data Form 

Ø Click in a single cell anywhere within the employee list (cells A1 through D14). Pull down the Data 
menu. Click Form to display a dialog box with data for the first record in the list (Adams). Click 
the New command button to clear the text box and begin entering a new record. 

Ø Enter the data for Elofson as shown the Figure below, using the Tab key to move from field to field 
within the data form. Click the Close command button after entering the salary (the last field). 
Elofson has been added to the list and appears in row 15 of the worksheet. 

 
Ø Save the workbook. 
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Step 3: Add a Record Using the Insert Row(s) Command 

Ø Click in the row heading for row 8. Pull down the Insert menu. Click Rows. (You can also right 
click, to get the shortcut menu, and select Insert).  

Ø Add the data for Gillenson, who works in Miami as an Account Rep with a salary of $55,000. 

Ø Save the workbook. 

 

 
Step4: The Spell Check 

Ø Select cells B2:C16. Pull down the Tools menu and click Spelling (or click on the Spelling 
button on the Standard Toolbar). 

Ø … 

Ø Save the workbook. 

 

 
Step 5: Sort the List 

Ø Click in a single cell anywhere in the employee list (cells A1 through D16). Pull down the Data 
menu. Click Sort to display the dialog box below: 

 
§ Click the drop-down arrow in the Sort by list box. Click Location as the primary key. 
§ Click the drop-down arrow in the first Then by list box. Click Name  as the secondary key. 
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§ Be sure the Header Row option button is checked (so that the field names are not mixed in 
with the records in the list). 

§ Check that the Ascending option button is selected for both the primary and secondary sort 
keys. 

§ Click OK to sort the list and return to the worksheet. 

Ø The employees are listed by location and alphabetically within location. 

Ø Save the workbook. 

 

 
Step 6: Delete a Record Using Data Form 

Ø Click a single cell within the employee list. 

Ø Pull down the Data menu. Click Form to display the data form. 

Ø Click the down arrow in the scroll bar until you come to the record for Frank. 

Ø Click the Delete command button. 

Ø Click OK in response to the warning message… [Note that the record cannot be undeleted when 
using the Data Form.] 

Ø Click Close to close the Data Form. 

Ø Save the workbook. 

 

 

Step 7: Insert a Field 

Ø Click the column heading in column D. Click the right mouse button to display a shortcut menu. 
Click Insert. The employee salaries have been moved to column E. 

Ø Click cell D1. Type Hire Date and press enter. Adjust the column width if necessary. 

 

 

Step 8: Enter the Hire Dates 

Ø Dates may be entered in several formats.  
§ Type 11/24/93 in cell D2. Press the down arrow key. 
§ Type Nov 24, 1993 in cell D3. Press the down arrow key. 
§ Type =Date(93,11,24) in cell D4. Press the down arrow key. 
§ Type 11-24-93 in cell D5. Press the down arrow key. 

Ø Let’s assume the next several employees were hired on the same day, 3/16/92.  
§ Click in cell D6. Type 3/16/92. Press enter. 
§ Click in cell D6. Click the Copy button on the Standard toolbar, which produces a “crawling 

ants” border around cell D6. Drag the mouse over cells D7 through D10. Click the Paste 
button on the Standard toolbar to complete the copy operation. 
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§ Press Esc to remove the “crawling ants” border around cell D6. 

Ø Let’s assume the last five employees were hired one year apart, beginning October 31, 1989.  
§ Click in cell D11. Type 10/31/89.  
§ Click in cell D12 and type 10/31/90. 
§ Select cells D11 and D12. 
§ Drag the fill handle at the bottom of cell D12 over cells D13, D14, and D15. Release the 

mouse to complete the AutoFill operation. 

Ø Save the workbook. 

 

Step 9: Format the Date  

Ø Click in the column heading for column D to select the column of dates. 

Ø Click the right mouse button to display a shortcut menu. Click Format cells. 

Ø Click the Number tab in the Format Cells dialog box. Click Date in the Category list box. Select 
(click) the date format you like…. Click OK. 

Ø Click elsewhere in the workbook to deselect the dates. Reduce the width of column D as 
appropriate.  

Ø Save the workbook. 

 

 

 
Hands-on Exercise 2 
Data Versus Information 
 
Objectives: To sort a list on multiple keys; to demonstrate the AutoFilter and Advanced AutoFilter 

commands; to define a named range; to use the DSUM, DAVERAGE, DMAX, DMIN, and 
DCOUNT functions.  

 
Step 1: Calculate the Years of Service 

Ø Start Excel. Open the Employees.xls workbook from the previous exercise… 

Ø Click the column heading in column D. Click the right mouse button to display a shortcut menu. 
Click Insert. The column of hire dates has been moved to column E. 

Ø Click in cell D1. Type Service and press enter. 

Ø Click in cell D2 and enter the formula to compute the years of service: =(TODAY()–E2)/365. 
Press enter; the years of service for the first employee is displayed in cell D2 (it should equal 4.5). 

§ Why not use the NOW() formula? 

Ø Click in cell D2, then click the Decrease Decimal button and the Formatting toolbar several 
times to display the length of service with only one decimal place. Reduce the column width as 
appropriate. 
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Ø Drag the fill handle in cell D2 to the remaining cells in that column (cells D3 through D15) to 
compute the years of service for the remaining employees. 

 
 
Step 2: The AutoFilter Command 

Ø Click a single cell anywhere within the list. Pull down the Data menu. Click the Filter command. 

Ø Click AutoFilter from the resulting cascade menu to display the drop-down arrows to the right of 
each field name. 

Ø Click the drop-down arrow next to Title to display the list of titles; select Account Rep. 

§ The display changes to show only those employees who meet the filter condition. 

§ The worksheet is unchanged, but only those rows containing account reps are visible. 

§ The row numbers for the visible records are blue. 

§ The drop-down arrow for Title is also blue, indicating that it is part of the filter condition. 

Ø Click the drop-down arrow next to Location. Click Boston to display only the employees in this 
city. The combination of the two filter conditions shows only the account reps in Boston. 

Ø Click the drop-down arrow next to Location a second time. Scroll until you can click All to 
remove the filter condition on location. Only the account reps are displayed because the filter on 
Title is still in effect.  

Ø Save the workbook. 

 
 
Step 3: The Custom AutoFilter Command 

Ø Click the drop-down arrow next to Salary to display the list of salaries. Click Custom to display 
the Custom AutoFilter dialog box below: 

 
Ø Click the arrow in the leftmost drop-down list box for Salary. Select the is greater than option 

from the drop-down list. 
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Ø Click in the text box for the salary amount. Type 45000 (or select $45,000 from the drop-down list 
next to the text box). Click OK. 

Ø The list changes to display only those employees whose title is account rep and who earn more than 
$45,000 per year. 

Ø Pull down the Data menu. Click Filter. Click AutoFilter to toggle the AutoFilter command off, 
which removes the arrows next to the field names and cancels all filter conditions. All of the records 
in the list are visible.  

 
 
Step 4: The Advanced Filter Command 

Ø The field names in the criteria range must be spelled exactly the same way as in the associated list. 
The best way to ensure that the names are identical is to copy the entries from the list to the criteria 
range. 
§ Click and drag to select cells A1 through F1. 
§ Click the Copy button on the Standard toolbar.  A crawling ants border appears around the 

selected cells. 
§ Click in cell A17. Click the Paste button on the Standard toolbar to complete the copy 

operation. Press Esc to cancel the crawling ants border. 

Ø Click in cell C18. Enter Manager (be sure you spell it correctly!). 

Ø Click in a single cell anywhere within the employee list. Pull down the Data menu. Click Filter. 
Click Advanced Filter from the resulting cascade menu to display the dialog box below. (The 
range is already entered because you had selected a cell in the list prior to executing the command.) 

 
Ø Click in the Criteria Range text box. Click in cell A17 in the worksheet and drag the mouse to 

cell F18. Release the mouse. A crawling ants border appears around these cells in the worksheet 
and the corresponding cell reference is entered in the dialog box. 

Ø Check that the option button to Filter the List, in-place is selected. Click OK. The display changes 
to show just the managers; that is, only rows 4, 8, and 10 are visible. 
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Ø Click in cell B18. Type Atlanta. Press enter. 

Ø Pull down the Data menu. Click Filter. Click Advanced Filter. The advanced Filter dialog box 
already has the cell references for the List and Criteria ranges (which were the last entries made). 

Ø Click OK. The display changes to show just the manager in Atlanta; that is, only row 4 is visible. 

Ø Pull down the Data menu. Click Filter. Click Show All to remove the filter conditions. The entire 
list is now visible. 

 
 
Step 5: The  Insert Name Command 

Ø Click and drag to select cells A1 through F15.  

Ø Pull down the Insert menu. Click Name . Click Define . Type Database in the Define Name 
dialog box. Click OK. [Alternatively, click in the Name box and type Database. Press enter.] 

Ø Click on the drop-down list in the Name box. There are two names in the list: Database, which you 
just defined, and Criteria, which was defined automatically when you specified the criteria range in 
step 4. 

Ø Select Criteria from the drop-down list to select the range (cells A17 through F18). Click 
elsewhere in the worksheet to deselect the cells. 

Ø Save the workbook. 
 
 
Step 6: Database Functions  

Ø Click in cell A21. Type Summary Statistics. Select cells A21 through F21, then click the Center 
Across Columns  button on the Formatting toolbar to center the heading over the selected cells. 

Ø Enter the following labels for cells A22 through A26: 
§ A22: Average Salary 
§ A23: Maximum Salary 
§ A24: Minimum Salary 
§ A25: Total Salary 
§ A26: Number of Employees 

Ø Click in cell B18. Press the Del key. The criteria range is now set to select only Managers. 

Ø Click in cell F22. Click the Paste Function button on the Standard toolbar to display the Paste 
Function dialog box. 

Ø Select Database from the Function Category list box. Select DAVERAGE as the Function Name, 
then click OK. The DAVERAGE function dialog box appears as shown below: 
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Ø Click in the Database text box in the function dialog box. Type Database (the range name defined 

in Step 5), which references the employee list. 

Ø Click in the Field text box in the function dialog box. Type “Salary”, the name of the field within 
the list that you want to average. 

Ø Click in the Criteria text box in the function dialog box. Type Criteria (the range name defined 
during the Advanced Filter operation). The result is shown in two places: just below the text boxes 
as = 69833, and at the bottom of the function dialog box as “Formula result = 69833”. 

Ø Click the OK button to enter the DAVERAGE function into the worksheet. 

Ø Save the workbook. 
 
 
Step 7: The DMAX, DMIN, DSUM, and DCOUNT Functions 

Ø Enter the DMAX, DMIN, DSUM, and DCOUNT functions in cells F23 through F26. You can use the 
Paste Function button to enter each function individually, or you can copy the DAVERAGE function 
and edit appropriately: 
§ = DMAX(Database, “Salary”, Criteria) 
§ = DMIN(Database, “Salary”, Criteria) 
§ = DSUM(Database, “Salary”, Criteria) 
§ = DCOUNT(Database, “Salary”, Criteria) 

Ø Select cells F22 through F25 and format these cells to currency with no decimals. Widen the 
column if necessary. 

Ø Save the workbook. 
 
 
Step 8: Changing the Criteria Range 

Ø Click in the Name box. Type B18 and press enter to make cell B18 the active cell. Type Chicago 
to change the criteria to Chicago managers. Press enter. 
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The values displayed by the DAVERGE, DMAX, DMIN, and DSUM functions change to $52,000, reflecting 
the one employee (Adamson) who meets the current criteria (a manager in Chicago). The value 
displayed by the DCOUNT function changes to 1 to indicate one employee. 

Ø Click in cell C18. Press the Del key. 

Ø The average salary changes to $45,125, reflecting all employees in Chicago. 

Ø Click in cell B18. Press the Del key. 

Ø The Criteria range is now empty. The DAVERAGE function displays $48,429, which is the average 
salary of all employees in the database. 

Ø Click in cell C18. Type Manager and press the enter key. The average salary is $69,833, the 
average salary for all managers. 

Ø Save the workbook. 
 



Inter 2  Page 11 of 16 

Hands-on Exercise 3 
Subtotals and Pivot Tables 
 
Objectives: To display and modify subtotals within a list; to use the PivotTable Wizard to create and 

modify a pivot table.  
 
Step 1: Open and Set Up the Workbook 

Ø Open the Employees.xls workbook from the previous exercise… 

Ø Click any cell in column C, the column containing the employee titles. Click the Sort ascending 
button on the Standard toolbar. The employees should be arranged according to title within the 
worksheet. [This is the field in which subtotals will be grouped.] 

Ø Point to the column heading in column D, which presently contains the length of service. Press the 
right mouse button to display a shortcut menu, Click Insert to insert a new column. 

Ø Click in cell D1. Type Gender (the field name). Press the down arrow key to move to cell D2. 
Type M. In the remaining cells in the range D3:D15, type M, F, F, F, M, F, F, M, M, M, F, M, 
F. 

Ø Narrow the column width as appropriate… and center the elements within the column. 

Ø Save the workbook. 

 
Step 2: Create the Subtotals 

Ø Click anywhere in the employee list. Pull down the Data menu. Click Subtotals to display the 
Subtotal dialog box shown below: 
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Ø Click the double-arrow in the “At Each Change in:” list box. Click Title to create a subtotal 
whenever there is a change in title. 

Ø Set the other options to match the dialog box shown above. The “Use function:” list box should be 
set to Sum; the “Add subtotal to:” list box should be set to Salary; the “Replace current subtotals” 
and “Summary below data” boxes should be checked. Click OK to create the subtotals. 

 
Step 3: Examine the Subtotals 

Ø Your worksheet should display subtotals in rows 11, 15, 18, and 19 (which contains a Grand 
Total). 

Ø Click in cell G11, the cell containing the Account Rep subtotal. The formula bar displays 
=SUBTOTAL(9,G12:G14), which computes the sum for cells G2 through G10. (The number 9 
within the argument of the function indicates a sum). 

Ø Click the level 2 button (just under the Name box) to suppress the detail lines. The list collapses to 
display the subtotals and grand total. 

Ø Click the level 1 button to suppress the subtotals. The list collapses further to display only the 
grand total. 

Ø Click the level 3 button to restore the detail lines and subtotals. The list expands to display the 
employee records, subtotals, and grand total. 
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Step 4: The PivotTable Wizard 

A pivot table extends the capability of individual database functions by presenting data in summary 
form. It divides the records in a list into categories, then computes summary statistics for those 
categories. 

Ø The subtotals must be cleared in order to create a pivot table. Click anywhere within the employee 
list or subtotals. Pull down the Data menu. Click Subtotals. Click the Remove All command 
button.  

Ø Rename the worksheet within the workbook: 

§ Double-click on the Sheet 1 tab and type List. Press enter. 

Ø Pull down the Data menu. Click PivotTable Report… to produce Step 1 of the PivotTable and 
Pivot Chart Wizard. The pre-selected radio buttons indicate that the pivot table will be created from 
data in a Microsoft Excel list or database, and only a Pivot Table will be created (not a Pivot Table 
and Pivot Chart). 

 
 

Ø Click the Next command button to move to step 2 of the PivotTable Wizard. You will see a dialog 
box where Database (the name assigned to the employee list in Hands-on Exercise 2) has already 
been entered in the Range text box. 
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Ø Click the Next command button to move to step 3 as shown in the Figure below: 

 
§ Choose New Worksheet if you want the pivot table to be created on a new worksheet in this 

workbook, 

§ We’ll choose Existing Worksheet to build the pivot table on the worksheet that contains the 
data. You must specify the cell in which the pivot table starts. With the cursor in that field, click 
on cell I1. 

Ø Click the Finish command button to create the pivot table and exit the PivotTable Wizard. Excel 
creates a “scaffold” onto which you can build a pivot table. (See screen shot below.) 

 
§ In the Pivot Table Toolbar, click the Title field text and drag it to the area labeled Drop Row 

Fields Here. 

§ Click the Location field text and drag it to the area labeled Drop Column Fields Here. 
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§ Click the Salary field text and drag it to the area labeled Drop Data Items Here. You will see 
“Sum of Salary” because Sum is the default computation for a numeric field, such as Salary. 
(Count is the default computation for a text field, such as Name.) 

 

Ø Save the workbook. 

 

 

Step 5: Modify the Pivot Table 

Ø The finished pivot table should look like the one shown in the Figure below. It displays the sum of 
the salaries by job title at each location. It also calculates a Grand Total of salaries paid by job title 
and a Grand Total of salaries paid at each location. 

 
 

Ø Now let’s change the data analyzed by the pivot table.  
§ Click and drag the Name field text from the PivotTable toolbar to the Data Items area. The 

button displays “Count of Name” (count is the default function for a text field). 
§ Click and drag the Gender field text to the page area (just above the “Sum of Salary” button. 
§ Click on the drop down list next to the Data button and uncheck “Sum of Salary”. 

Ø The pivot table changes to display the number of employees for each location-title combination. 
Note that there are two Account Reps and no Managers or Trainees in Miami. 

 
 
Step 6: Modify the Employee List 

Ø Scroll to the left to return to the list of employees. 

Ø Click in cell C10. Type Manager. Press enter to change Gillenson’s title from Account Rep to 
Manager. Note that Gillenson works in Miami. 

Ø Click the Pivot Table to return to the pivot table. There are still two Account Reps and no 
Managers or Trainees in Miami because Gillenson’s change is not yet reflected in the pivot table. 
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Ø Click on the Refresh Data button ( ) on the Pivot toolbar to update the pivot table. 

Ø Miami now has one manager and one Account Rep … 

Ø Save the workbook. 

 

Step 7: Pivot the Table  

Ø The pivot table should match the one shown above, with Gender, Title, and Location as the page, 
row, and column fields, respectively. 

Ø Click and drag the Gender button next to the Location button. The page field disappears and there 
are now two column fields, Gender and Location. 

Ø Click and drag the Location button to the previous location of the Gender field (cell I1) to make 
Location a page field. You have changed the orientation of the table and have a completely different 
analysis. 

Ø The new, modified pivot table is shown below. Location is now the page field and Gender is now 
the column field. This arrangement of the table makes it easy to see the number of male and female 
employees in each job classification. 

 
Ø Save the workbook. Exit Excel. 
 


